Prestashop 1.5 : résoudre le bug de paiement par chèque/virement bancaire

1 déc

La sortie de la version 1.5 a soulevé autant d’enthousiasme que d’inquiétude dans la communauté Prestashop et ses partenaires. De l’enthousiasme car cette nouvelle version est une vraie grosse évolution pour ce célèbre outil open-source, mais aussi de l’inquiétude car cette version est sortie non sans grandes difficultés, et de très nombreux bugs…

Un des principaux bugs est l’impossibilité de payer… et donc de finaliser une commande… enfin… la commande s’ajoute bien dans la base de données, mais le client est redirigé… vers une jolie page blanche (genre erreur serveur)…

Heureusement, nous avons la solution :) et vous allez voir, c’est tout bête !

L’erreur vient en fait d’un module installé par défaut (si vous cochez la case « installez les 100 modules » lors de l’installation de PS1.5), à savoir Colissimo.

En effet, celui-ci, s’il n’est pas configuré par l’administrateur, fait tout bonnement planter l’application, sans avertissement et sans message d’erreur clair (même en mode debug).

Je comprends un peu mieux pourquoi Prestashop disait ne pas réussir à reproduire le bug, et pourquoi ils ont clôturé les tickets ouverts chez eux (http://forge.prestashop.com/browse/PSCFV-4987http://forge.prestashop.com/browse/PNM-665?page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel)

Donc, deux solutions s’offrent à vous :

  1. Configurer correctement le module Colissimo
  2. Ou bien le désinstaller :)

Et là tadddddddddda, magie, le client est bien redirigé vers la page de confirmation de paiement :D (assurez-vous bien d’avoir d’autres modes de livraison cependant) !!!!

 

Un problème de moins donc, mais une question me vient à l’esprit :
Oui le module Colissimo affiche des warning sur la page des modules, mais pourquoi diable ne pas bloquer ce mode de livraison si la configuration n’est pas bonne???

3 Responses to “Prestashop 1.5 : résoudre le bug de paiement par chèque/virement bancaire”

  1. Myjr 03. mar, 2013 at 20 h 43 min #

    Merci pour ce post… trois jours que je galère dessus et enfin une réponse !
    Donc merci :)

  2. Gihel59 16. mai, 2013 at 15 h 55 min #

    Yessssssssssssss
    Super. Vous êtes géniaux.
    En fait, je suis en 1.4.9 et j’ai le même problème.
    Allez, je cours désinstaller colissimo (par ailleurs non configuré).

    Merci !

  3. carlos 23. mai, 2013 at 21 h 42 min #

    Grand merci à toi :o )

Leave a Reply

*